Customers Incorrectly presented with Demo Mailbox
Incident Report for Groove
Resolved
We've rolled out the fix and all customers should now be able to access Groove correctly.
Posted 4 months ago. May 21, 2019 - 08:23 GMT-05:00
Identified
We're identified the issue and rolling out a fix right now.
Posted 4 months ago. May 21, 2019 - 08:20 GMT-05:00
Investigating
We've noticed an issue where customers are erroneously presented with a demo mailbox when they have a fully working mailbox. We are currently investigating what's causing the issue.
Posted 4 months ago. May 21, 2019 - 07:18 GMT-05:00
This incident affected: Web App and Inbox API.