Degraded service on Groove inbox (Delayed mail fetching, collision detection, realtime updates, sending mail)

Incident Report for Groove

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 13:15 GMT-05:00

Monitoring

A fix has been implemented and we are monitoring the results - backlog is currently clearing over the next 30-60 minutes.

Expected delays for incoming mails, outgoing mails being sent, rule processing, realtime, and other features during this time.
Posted Jun 02, 2025 - 12:23 GMT-05:00

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2025 - 09:13 GMT-05:00
This incident affected: Inbox Channels (Email) and Web App, Inbox API.