Degraded service on Groove inbox (Delayed mail fetching, collision detection, realtime updates)
Incident Report for Groove
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 07:50 GMT-05:00
Update
We are continuing to work on a fix for this issue.
Posted Feb 01, 2023 - 04:31 GMT-05:00
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 01, 2023 - 04:30 GMT-05:00
This incident affected: Web App.