Customers Incorrectly presented with Demo Mailbox
Incident Report for Groove
Resolved
This incident has been resolved.
Posted 4 months ago. May 22, 2019 - 09:14 GMT-05:00
Update
Issue has been identified and a fix will be rolled out in a few moments.
Posted 4 months ago. May 22, 2019 - 08:53 GMT-05:00
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. May 22, 2019 - 08:52 GMT-05:00
This incident affected: Web App and Inbox API.