SMTP - Mail delivery issues

Incident Report for Groove

Resolved

This incident has been resolved.
Posted May 28, 2026 - 15:00 GMT-05:00

Investigating

We're investigating an issue with an upstream SMTP provider causing issue with mail delivery
Posted May 28, 2026 - 10:47 GMT-05:00
This incident affected: Web App and Inbox API.